6

If I run the command:

$> meteor add ethereum:web3

I get the following error message:

 => Errors while adding packages:             

While checking for ethereum:web3@0.18.4:
error: No compatible binary build found for this package. Contact the package author and ask them to publish it for your platform.

Does anybody have an idea what is going on here?

  • I am also having the same problem. Please let me know if you get the solution. – user3606212 Apr 2 '17 at 23:37
  • I had a similar error with a nodejs package last week, could you point us to the docs where you found that instructions to add ethereum:web3? – Afr Apr 3 '17 at 7:29
  • The instructions are probably these: github.com/ethereum/wiki/wiki/… – Richard Horrocks Apr 3 '17 at 16:31
  • 1
    I used the command: $ meteor add ethereum:tools . This obviously installed the ethereum:web3 but with the version 0.15.3. – Bumblebee Apr 4 '17 at 6:24
5

In windows cmd: meteor add ethereum:web3@=0.18.3

Just add the previous version, worked for me.

| improve this answer | |
  • 1
    Like @Miguel mentioned it workes loading previous version – Antoni Hauptmann Apr 19 '17 at 9:07
  • That worked for me on a linux system as well – Bumblebee Apr 26 '17 at 18:57
4

Using $ meteor add ethereum:tools worked for me. As you may see below, it added web3. Thanks

3stack:bignumber added, version 2.0.0 amplify added, version 1.0.0 ethereum:tools added, version 0.6.0 ethereum:web3 added, version 0.15.3 frozeman:persistent-minimongo added, version 0.1.8 frozeman:storage added, version 0.1.9 localstorage added, version 1.0.12

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.