1

I followed these instructions and everything works until I try to add a new non-authority node form another machine. (Point 8)

The authority nodes are running on Microsoft Azure and they are connected to each other (0/1/25 peers) and work fine.

I've tried all the commands and suggestions I can find online, but nothing works. I get the enode:// of the authority node and then use the command

curl --data '{"jsonrpc":"2.0","method":"parity_addReservedPeer","params":["enode://RESULT"],"id":0}' -H "Content-Type: application/json" -X POST localhost:8540 

with the correct enode number and i get result "true"

curl --data '{"jsonrpc":"2.0","method":"parity_addReservedPeer","params":["enode://2aba3164aee2b387ed20ca917766728ba36853cd52490787778a9dee4a21167de40c936459e054ee0a6bf462e72864d1ad93d9a3aa288481d222c854d43c0e06@10.0.2.5:30300"],"id":0}' -H "Content-Type: application/json" -X POST localhost:8540
{"jsonrpc":"2.0","result":true,"id":0}

but then the node is not connected to the private network.

Any help would be very appreciated because I've busting my head on this for ages now.

Thanks in advance


From the authority node I get the following:

2017-04-01 15:53:05 UTC hyper-client INFO miner  Updated conversion rate to Ξ1 = US$51.06 (2331523800 wei/gas)
2017-04-01 15:53:11 UTC IO Worker #3 INFO network  Public node URL: enode://21aa6d918053948b0dbb378aeff28ba7900158a0a7ae0a3e9b3b4df060637c19376a7a40e4ab6a1440ac1f8de6d2c2a00887f782b5af832da692c5bdffc3c354@10.0.2.4:30300
2017-04-01 15:53:11 UTC IO Worker #0 TRACE sync  == Connected 1: Parity/v1.6.5-beta-987390f-20170328/x86_64-linux-gnu/rustc1.16.0
2017-04-01 15:53:11 UTC IO Worker #0 TRACE sync  Sending status to 1, protocol version 2
2017-04-01 15:53:11 UTC IO Worker #0 TRACE sync  New peer 1 (protocol: 2, network: 8995, difficulty: Some(524288), latest:1198…fb89, genesis:a662…6e45, snapshot:Some(0))
2017-04-01 15:53:11 UTC IO Worker #0 DEBUG sync  Connected 1:Parity/v1.6.5-beta-987390f-20170328/x86_64-linux-gnu/rustc1.16.0
2017-04-01 15:53:11 UTC IO Worker #0 TRACE sync  Skipping peer 1, force=false, td=Some(524288), our td=524288, state=WaitingPeers
2017-04-01 15:53:16 UTC IO Worker #3 INFO import  Syncing       #3 1198…fb89     0 blk/s    0 tx/s   0 Mgas/s      0+    0 Qed        #3    0/ 1/25 peers     9 KiB db    8 KiB chain  0 bytes queue   10 KiB sync  RPC:  0 conn,  0 req/s,   0 µs
2017-04-01 15:53:17 UTC IO Worker #1 TRACE sync  No snapshots found, starting full sync
2017-04-01 15:53:17 UTC IO Worker #1 TRACE sync  Syncing with peers: 1 active, 1 confirmed, 1 total
2017-04-01 15:53:17 UTC IO Worker #1 TRACE sync  Skipping peer 1, force=false, td=Some(524288), our td=524288, state=Idle
2017-04-01 15:53:46 UTC IO Worker #2 INFO import     0/ 1/25 peers     9 KiB db    8 KiB chain  0 bytes queue   10 KiB sync  RPC:  0 conn,  0 req/s,   0 µs
2017-04-01 15:54:16 UTC IO Worker #2 INFO import     0/ 1/25 peers     9 KiB db    8 KiB chain  0 bytes queue   10 KiB sync  RPC:  0 conn,  0 req/s,   0 µs

From the non-authority that i try to add without success, this:

parity --config /tmp/parity0/node3.toml -lsync=trace
Loading config file from /tmp/parity0/node3.toml
2017-04-01 17:52:37  main INFO parity::run  Starting Parity/v1.6.5-beta-987390f-20170328/x86_64-linux-gnu/rustc1.16.0
2017-04-01 17:52:37  main INFO parity::run  State DB configuration: fast
2017-04-01 17:52:37  main INFO parity::run  Operating mode: active
2017-04-01 17:52:37  main INFO ethcore::service  Configured for GregSimoPoA using AuthorityRound engine
2017-04-01 17:52:38  hyper-client INFO miner  Updated conversion rate to Ξ1 = US$50.93 (2337475300 wei/gas)
2017-04-01 17:52:43  IO Worker #2 INFO network  Public node URL: enode://88a502f2a9face748dce55fa2c59fd749d29339d63378a87da49b15fa6d8d10d4d4d7de25a7b1ec4fb81a28faabf5e3834ae4371df07afdc24527bfc8bec2c36@192.168.1.34:30300
2017-04-01 17:52:48  IO Worker #1 INFO import  Syncing       #0 a662…6e45     0 blk/s    0 tx/s   0 Mgas/s      0+    0 Qed        #0    0/ 0/25 peers     7 KiB db    7 KiB chain  0 bytes queue 448 bytes sync  RPC:  0 conn,  0 req/s, 333 µs
2017-04-01 17:52:53  IO Worker #0 INFO import  Syncing       #0 a662…6e45     0 blk/s    0 tx/s   0 Mgas/s      0+    0 Qed        #0    0/ 0/25 peers     7 KiB db    7 KiB chain  0 bytes queue 448 bytes sync  RPC:  0 conn,  0 req/s, 333 µs
  • Can you run the node with -lsync=trace and paste it somewhere? – Waqar Lim Mar 31 '17 at 11:07
  • I posted the comment in the answers because it was too long. – simoh92 Apr 1 '17 at 16:02
  • Please don't use answers for additional information, you can always edit your question. Did that for you now. – Waqar Lim Apr 3 '17 at 7:14
  • The logs dont really show any activity. Is 10.0.2.x a local network? If they run on Azure, can you try to replace the IP with the public one? – Waqar Lim Apr 3 '17 at 7:24
  • Sorry, it was my first time posting on stackexchange. I tried to run the same command using the same IP I used to ssh to the virtual machine in Azure, but still nothing. – simoh92 Apr 4 '17 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.