0

I'm trying to create a 'Near' bootstrap application using this command npx create-near-app blockvote --contract js --frontend react --tests js.

This isn't creating bootstrap files as it should. The only message I'm getting is

 ======================================================
👋 Welcome to NEAR! Learn more: https://docs.near.org/
🔧 Let's get your dApp ready.
======================================================
(NEAR collects anonymous information on the commands used. No personal information that could identify you is shared)

Notice: On Win32 please use WSL (Windows Subsystem for Linux).
https://docs.microsoft.com/en-us/windows/wsl/install
Exiting now.

I require this for my final year project.
Thanks in advance !

1 Answer 1

1

If you are using Windows, you need to install Linux on Windows with WSL first. If you are using Mac, the command npx create-near-app blockvote --contract js --frontend react --tests js will create the bootstrap application.

See: https://learn.microsoft.com/en-us/windows/wsl/install

1
  • I get this error message on WSL - Ubuntu. create-near-app still thinks I am on windows. Anyone?
    – Suisse
    Nov 2, 2022 at 17:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.