3

After upgrading geth node to new Ropsten testnet node is not mining anymore, even though log messages seem it is trying to:

I0328 09:51:54.537322 miner/worker.go:542] commit new work on block 645501 with 3 txs & 0 uncles. Took 7.0169ms
I0328 09:51:54.510653 core/blockchain.go:1042] imported 1 blocks,     1 txs (  2.461 Mg) in  19.615ms (125.473 Mg/s). #645500 [decf1899…]
I0328 09:51:49.199444 miner/worker.go:542] commit new work on block 645500 with 3 txs & 0 uncles. Took 10.9284ms
I0328 09:51:49.188250 core/blockchain.go:1042] imported 1 blocks,     0 txs (  0.000 Mg) in   8.887ms ( 0.000 Mg/s). #645499 [d7e75631…]
I0328 09:51:41.826702 miner/worker.go:542] commit new work on block 645499 with 2 txs & 0 uncles. Took 1.0329ms
I0328 09:51:41.825596 core/blockchain.go:1042] imported 1 blocks,     0 txs (  0.000 Mg) in   2.866ms ( 0.000 Mg/s). #645498 [4fde3f80…]
I0328 09:51:40.335148 miner/worker.go:542] commit new work on block 645498 with 2 txs & 0 uncles. Took 1.0338ms

The miner address is the following:

https://ropsten.etherscan.io/address/0xf28dafbfeb41bf32869c9d498da0d651d0206ed4#mine

The command line to launch geth node is this one:

geth --testnet --rpc --rpcapi "db,eth,net,web3,personal" --mine --etherbase "0xf28dafbfeb41bf32869c9d498da0d651d0206ed4" --gasprice "1000000000" --bootnodes "enode://20c9ad97c081d63397d7b685a412227a40e23c8bdc6688c6f37e97cfbc22d2b4d1db1510d8f61e6a8866ad7f0e17c02b14182d37ea7c3c8b9c2683aeb6b733a1@52.169.14.227:30303,enode://6ce05930c72abc632c58e2e4324f7c7ea478cec0ed4fa2528982cf34483094e9cbc9216e7aa349691242576d552a2a56aaeae426c5303ded677ce455ba1acd9d@13.84.180.240:30303"

After 2 days mining the geth node got 1 block mined:

https://ropsten.etherscan.io/block/653885

Before Ropsten the same node was mining at a rate of 2 blocks per hour, but now it mines at 1 block per day or even slower.

Any hint about what is happening? Thx!

2
+50

I'd suspect this is what has happened.

The current hash rate (as of Ropsten block 673252) is 0.011 GH/s, with the difficulty being 134,588,276.

Prior to the recent spam attacks, if we take block 586946 as an example from before the attack started, the hash rate was ~0.005 GH/s and the difficulty 105,432,944.

The Ropsten testnet was rescued from the spam attack by the donation of significant hash power, which was able to mine a completely new chain starting from before the attack, and replay all the transactions since. I'm suspecting that some of this hash power has remained in the network to help prevent the attack from reoccurring.

You're now mining in a more competitive, but safer, test network.

  • Hash rate and difficulty has changed (2x higher) but not in the same order than the mining speed of the node (10x slower) – Juan Ignacio Pérez Sacristán Apr 3 '17 at 8:25
0

Now it is mining at 2 blocks per hour. It seems something happened to the network the days before, but I still don't know what it was.

  • It is happening again, last 10 hours the miner is sending broadcasting new blocks but they have not been mined. Any idea what is the problem? – Juan Ignacio Pérez Sacristán Apr 7 '17 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.