1

according to uniswap v3 docs we should install these modules:

npm i --save-dev @uniswap/v3-sdk npm i --save-dev @uniswap/sdk-core

then for the quoter abi: @uniswap/v3-periphery/artifacts/contracts/lens/Quoter.sol/Quoter.json

but there is no directory for @uniswap/v3-periphery/artifacts

so always get an error

Error: Cannot find module '@uniswap/v3-periphery/artifacts/contracts/lens/Quoter.sol/Quoter.json'

5 Answers 5

1

the recent version (1.4.2) has a problem I think. the package does not contain the artifacts folder. I installed a previous version and it worked.

$ yarn add -D @uniswap/[email protected]
0

Had the same issue, solved it by cd into the node_modules/@uniswap/v3-periphery, run npm i followed by npx hardhat compile.

Hope this helps.

0

Have you installed @uniswap/v3-periphery?

npm i --save-dev @uniswap/v3-periphery

afterward, just import it. Hope this helps!

0

yarn add -D @uniswap/[email protected]

This worked for me, but since I don't have enough reputation, I can't comment or upvote. Original answer can be found here consider upvoting it if it works for you

0

I have this version installed:

      "@uniswap/v3-periphery": "^1.4.3",

and it works

import UniswapV3Quote from "@uniswap/v3-periphery/artifacts/contracts/lens/Quoter.sol/Quoter.json";
console.log({ UniswapV3Quote });

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.