0

Case: We have a bunch of contracts with version 6.0.0. The upgradeability implemented using @openzeppelin/contracts-ethereum-package libraries

How can I upgrade the solidity version to latest and avoid a lot of conflicts and problems with a layouts?

1 Answer 1

0

You can upgrade the new implementations and underlying logic, but you can't adjust upgrade the solidity version on your main proxy contract (it's stuck for good). Hardhat and most dev suites allow you to test and use different solidity versions, so just be sure to test it out and make sure they're compatible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.