0

enter image description here

I'm working with foundry. Forge seems to be installed but I get ZOE ERROR whenever I run it. Any idea why?

2 Answers 2

0

There is a conflict between forge as a package with ubuntu. When you run which forge in the terminal you get /usr/bin/forge which is not actually what we need. Instead, if you want to use forge /.foundry/bin/forge --version should definitely work.

Inorder to resolve the issue what you can do is add alias forge='~/.foundry/bin/forge' in your ~/.bashrc file

2
  • Chiranjibi Poudyal could you expand your answer . Bcoz i have same error Nov 23, 2022 at 15:02
  • What I mean is ubuntu already has a forge package installed. And there's a conflict when we call forge thinking it's a package created by foundry. When we call forge the package ubuntu runs by default is which is available at /usr/bin/forge but what we actually want to run is ~/.foundry/bin/forge. That's the reason why we need to add alias to our ~/.bashrc. Nov 29, 2022 at 6:38
0

just 3 steps:

  1. open ~/.bashrc by:
sudo nano ~/.bashrc
  1. then add this line at last:
/.foundry/bin/forge --version
  1. save and exit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.