3

I am using etherchain-light which works really nice together with Parity PoA and the demo tutorial for Parity PoA private chains.

I experienced two weird issue, in general everything works perfect with the two signer accounts, I can deploy contracts even with browser-solidity, call them, transfer ether, etc.

However, if I use the user account (0x004ec07d2329997267Ec62b4166639513386F32E):

  1. when I deploy a contract (using browser-solidity) with a library, the signer accounts (eg. 0x00Bd138aBD70e2F00903268F3Db08f2D25677C9e) has to accept two trx, and it's working. If a change the account to the "user" account 0x004ec07d2329997267Ec62b4166639513386F32E, only one trx has to be accepted, but browser-solidity does not return, the contracts are never deployed.

  2. After some time, even transfer of Ether from user account does not work any more. I can accept the trx, but then it goes to pending trxs, which get never "mined". I can see a lot of pending transactions in etherchain-light, which obviously never get confirmed. Something is strange here, it worked at the beginning and stopped suddenly, queueing all trx from the user account in pending transactions.

So, in short: there seems to be a difference between signer accounts and user accounts which I do not grasp. But I would like user accounts to have the same privileges as the signer account.

  • Just to eliminate a possible cause: Did you try to supply more gas with the contract deployment transaction sent from the user account? Also, does the user account have enough ether to pay for the gas needed, at the current gas price? – Ajoy Bhatia Mar 26 '17 at 22:08
  • yes , enough gas present and validators should also accept 0 eth trx by config. I cleaned the db and restarted and now it works flawlessly with the same setup. – Ice09 Mar 27 '17 at 6:31
1

You would need to provide more info, such as provided gas and tx_queue=trace log. A good place to debug is the gitter.

However in general, an issue like that may occur if a transaction with gas exceeding the block gas limit is submitted. In private chains (just like in public) the gas limit can change at a limited rate towards the --gas-floor-target. The tutorial genesis spec has a higher gas limit than the default --gas-floor-target which means that the gas limit will go down at the beginning of the chain.
You can solve it either by ensuring you do not submit transactions with more gas than the --gas-floor-target of your authorities or increasing the target.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.