5

What version of geth do i need for the merge? Will my node with Vectra (v1.10.20) run smoothly after the merge without updating to the latest version?

0

2 Answers 2

5

You will need at least Geth version 1.10.23 (Sentry Omega).

https://blog.ethereum.org/2022/08/24/mainnet-merge-announcement

In addition to Geth (an execution layer client), you will also need to run a consensus layer client as in the announcement above, and then authenticate (connect) them as described below.


Install a consensus layer client

https://ethereum.org/en/upgrades/merge/#preparing-for-the-merge

Assuming you are a Non-validating node operator, key action items include:

Authenticating the clients

https://launchpad.ethereum.org/en/merge-readiness/#authenticate

Communication between the execution layer and consensus layer will occur using the Engine API. This is a new set of JSON RPC methods that can be used to communicate between the two client layers.

Instructions for how to set this JWT secret vary depending on the client — node operators should refer to their clients' documentation for instructions about how to generate and configure these.

2

here is a good writeup for the current situation: https://blog.ethereum.org/2022/08/24/mainnet-merge-announcement/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.