2

I'm having a problem on a new ethereum install on a Mac:

Fatal: Error starting protocol stack: listen udp :30303: bind: address already in use

Any suggestions to fix would be greatly appreciated.

2

You might have already installed and launched an geth instance before. It might as well be other services listen on the same port, though very unlikely.

You can use the following command to kill the existing process:

$ # Get <PID> of the process occupying the port
$ lsof -i tcp:30303
$ kill -QUIT <PID> 

Then reload the wallet.

| improve this answer | |
  • It would be better to try kill -INT <pid> first as Geth has an explicit handler for SIGINTs but not for SIGQUITs. That way if there is an instance already running, it's more likely to exit gracefully. (Also, a QUIT signal leads to an explicit core dump.) ethereum.stackexchange.com/questions/10566/… – Richard Horrocks Mar 22 '17 at 9:28
  • Tried kill -INT <pid> first, still had issue, then used kill -QUIT <PID>, issue solved! – BioponX Mar 22 '17 at 13:31
  • Glad to know it's resolved! – Yuanfei Zhu Mar 23 '17 at 2:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.