0

I'm trying to deploy a contract to the Polygon Mumbai testnet and transactions just don't get processed, even after more than two days.

I've tried setting higher gas amounts. I've also tried both Truffle and Hardhat and many different RPC URLs and nothings works, the transactions don't even show up as pending in the block explorer.

I don't get any error response, it just times out. As a comparison I deployed the exact same contract to the Goerli testnet and Avalanche Fuji testnet with no issues at all.

My Hardhat network config looks like this:

mumbai: {
  url: `https://polygon-mumbai.g.alchemy.com/v2/${process.env.ALCHEMY_API_KEY}`,
  chainId: 80001,
},
goerli: {
  url: `https://eth-goerli.g.alchemy.com/v2/${process.env.ALCHEMY_API_KEY}`,
  chainId: 5,
},
fuji: {
  url: `https://api.avax-test.network/ext/bc/C/rpc`,
  chainId: 43113,
},

Any help with debugging this would be much appreciated.

2 Answers 2

2

The issue can be Linked to either :

1- the RPC url

2- the provider

3- THE WALLET ADDRESS, this has happened to me on the mumbai testnet alot and to solve it, i switched the wallet address to a brand new one, made only for deployments. and used another wallet address for contract interaction, because it seems that on mumbai the wallet address has a certain type of quota on calls/deployments basically blockchain interactions

5
  • Yes it does look like it might be some kind of quota or rate limiting. I found another post that said sending yourself a transaction of 0 MATIC would solve it. I tried that and it actually did process 2 pending contract creation transactions at the same time. But unfortunately creating new contracts after that still didn't work. Commented Aug 8, 2022 at 15:03
  • sometimes an address gets stuck and all of the transactions made with it will be put in a queue and when the first one works, they all work along with it. try using a brand new Address to deploy and interact and don't use this address on other stuff, it will solve your issue. sometimes my transactions would be pending for hours and then suddenly they all get confirmed after 10-14 hours
    – anthony422
    Commented Aug 9, 2022 at 8:33
  • You are right a new address did work properly. It would be great to know how to "unstuck" an address though. Commented Aug 9, 2022 at 8:50
  • I've had random spikes in gas for transactions that are the same, like trying to rapidly debug deployed smart contracts by deploying a bunch of the same but slightly different can run into issues.
    – Danny B
    Commented Aug 9, 2022 at 15:14
  • usually an address gets stuck for max 24 hrs, i was never able to "unstuck" it, all i can do is wait... , a good solution that you should do is add to your contract an array of admins, that way if this address gets stuck you can use another address and continue with your life.
    – anthony422
    Commented Aug 10, 2022 at 9:14
1

The Mumbai testnet is running and processing transactions as evidenced eg by the explorer.

If you have an endpoint issue, I suggest trying a different provider. e.g. Chainstack.

1
  • Yes I know it's processing other transactions. It also processes transactions I send from the same account on MetaMask. It's just creating new contracts which does not seem to work properly. Commented Aug 8, 2022 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.