1

I'm currently learning Solidity and smart contracts and while I was trying to deploy my contract on the Rinkeby Test Network, suddenly Remix IDE does not allow me to switch the environment option to "Injected Provider - Metamask".

enter image description here

I've already deployed another contract but I never experienced this problem. To clarify, I can switch to every other environment option such as "Remix VM (Berlin), "Hardhat Provider" and so on but I cannot switch to "Injected Provider - Metamask". I do not encounter any error, it simply does not switch the option when I click it. The browser that I'm using is Brave, Version 1.42.86, with Metamask extension installed.

Hope someone can help me, thank you for the attention.

5 Answers 5

1

Try logging into metamask and then try to switch the environment option to "Injected Provider - Metamask".

1
  • Unfortunately it seems that it doesn't work... I've also tried to switch to Chrome but I've the same exact problem. Also tried to reinstall from scratch the Metamask extension multiple times but it does not work anyway.
    – Futtano
    Aug 4, 2022 at 18:03
1

I had the same issue. This is a two-part problem. As of now, Rinkeby has been deprecated so it is recommended that you use Goerli. Ensure you change your test network within MetaMask to Goerli (if that's the testnet you are using).

I was able to resolve the Injected Provider portion of the issue by doing the following steps:

  • download the workspace locally
  • close Remix
  • upload the workspace
  • ensure the compiler is 0.8.8+
  • change the environment to Injected Provider and connect MetaMask account

Hope this helps!

1

Just update the metamask extension.

Credits: This video walks through how to update the metamask extension and solve the issue.

0

Following either of the following solutions should solve the problem on the Online IDE (it did for me):

  1. Refresh the Remix tab, and ensure that you have only 1 Remix tab open.
  2. Sign in to your MetaMask before you launch the Remix IDE online.

From my experience, I understand that Remix does not detect MetaMask being logged in. The IDE has to be refreshed for the login update.

0

Sorry for ressurrecting this question, but it's just in case someone is having this same problem and the fixes here don't solve the problem. like my case... What was causing this problem for me was the experimental setting "Select networks for each site" being turned on. After turning it off and hard refreshing the page (ctrl + F5), it was solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.