0

I got a problem which i can’t understand the reason. Made a erc20 token, and deployed on testnet Here everything goes fine and work as expected, But when i deployed it on mainnet, the block explorer shows holders are 0 Also holders tab is empty. And in addition, tokens are displaying on metamask, but not visible in token holder wallet on block explorer.

Is there anybody who knows the problem?? It very weird for me. Cause it’s okay on testnet but not on mainnet!

I searched for it on google, but there is just few results about the problme, and those are just saying about Transfer event and emitting it for minting the token. This is not my case, cause i have all the events and checked them hundred times.

I cross my fingers hoping someone helps me getting this solved🙏

4
  • have a link to the token?
    – thefett
    Jul 29 at 12:21
  • Etherscan/Bscscan are closed source third party block explorer. We don't know how they handle contracts and tokens. In the past verifying the contract and performing at least one transfer will identify the contract as a token. I'll suggest to contact their customer support.
    – Ismael
    Jul 30 at 4:32
  • as bscscan placed a notification bar on their website, it seems there is an issue on new token balances on Binance smart chain explorer which they are trying to resolve. I checked some other new tokens, and they have the same situation...many transactions but 0 holders.
    – bghad1
    Jul 30 at 5:41

1 Answer 1

0

All block explorers are "eventually consistent", meaning the data might not be real time or up to date all of the time, but it eventually will be.

Most block explorers use Transfer events from the ERC20 specification to figure out how many holders there are and so on, but since this is likely a low priority job, especially for largely unknown tokens, it might not be visible instantly.

This largely depends on the block explorer, though. If you used Etherscan on testnet, and you use Etherscan on mainnet, it will show up eventually, if it is the same contract, and it worked on testnet.

1
  • The token holders are okay in testnets(bsc and eth)…but on mainnet, it is showing 0 holders! It’s an strange happening to me
    – bghad1
    Jul 29 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.