2

Sorry if this type of question has been asked before, but I have not found any questions dealing with this scenario. I am using Geth and am kind of new to this thing. I bought some Ether on Coinbase a while back and initiated a transfer to my Geth account address from Coinbase and was able to see that it successfully occurred.

Now, I want send that amount back to my Coinbase address and I used the following command in the Geth console (replacing xxx with the actual addresses):

eth.sendTransaction({from: '0xAf2999f18d582086Ce62209ef4701E6F23066C1C', to: '0x7DD98A5581c3d9BA1dfF9C7894368Cb434351B7C', value: web3.toWei(5, "ether")}

This has been running for probably 30 minutes and the only output I have received from the Geth console are three periods (...). It is important to note that I have not fully synchronized with the Blockchain (because it will take several more days, due to disk I/O) and the console still shows some block updates while this is still running:

enter image description here

Geth also showed a balanced of 0 ETH before I sent the transaction. I know that my address has 5 ETH due to the confirmation I can see on etherscan.io.

Will this transaction ever resolve? If not, is it safe to CTRL + C out of it? When would I be able to actually send out a transaction?

I tried using Ethereum Wallet, but when I pressed send, nothing actually happened. Similar, Ethereum Wallet wanted me to create a contract to view my balance, but that contract had a cost associated with it, so I did not proceed with that.

  • Hi Mark. Things aren't going to "catch up" and look right until the chain is synced. – Rob Hitchens - B9lab Mar 18 '17 at 18:10
1

Important:

With commands like this, especially if this is the first time you've tried it, it's always better to test things out using a small amount of ether.


The actual problem is that you're missing the closing bracket on your command. Each opening bracket (parenthesis), and each curly bracket needs an equivalent closing bracket. You need another ) at the end. I'd cancel this command using ctrl + c and try re-running it.


As an alternative, you could use something like myetherwallet.com

  • I can't believe I was missing the closing parentheses. Did not even notice it. Thanks! – Mark W Mar 18 '17 at 18:02
  • If I try to send a small amount, I get the error Insufficient funds for gas * price + value. I assume this is because my blockchain is not fully synchronized and it does not know I have ETH in this address yet. Is that correct? – Mark W Mar 18 '17 at 18:11
  • You have to cover the gas cost of the transaction itself (the transaction fee). The default fee is 21,000 wei, so try specifying something a bit larger than that. – Richard Horrocks Mar 18 '17 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.