2

I tried to setup a ETH miner on Linux Ubuntu 16.04.2 together with Jaxx. But it was too messy. Can someone go through step by step together with me?

  • Hi there. What instructions were you following when you ran into a messy dead end? Asking a specific question about a particular part of the process you were following is more likely to get responses. – Richard Horrocks Mar 17 '17 at 14:27
  • i tried following this tutorial. meebey.net/posts/ethereum_gpu_mining_on_linux_howto – TarekKK Mar 17 '17 at 14:30
  • Is Ethereumpool.co still up? I thought they stopped in Januari 2017... – SODA Jun 2 '17 at 21:14
2

I myself am on the Ethereumpool.co pool. Also, I am on Linux 16.04, the problem you said is that you can't get it together with Jaxx? So first off you need to install the Prerequisites. Open a terminal and type the following one at a time.

sudo apt-get clean 
sudo add-apt-repository -y ppa:ethereum/ethereum-qt 
sudo add-apt-repository -y ppa:ethereum/ethereum 
sudo apt-get update 
sudo apt-get install cpp-ethereum

After you do that, I suggest making a note file to keep your starting command. To connect to the pool, you want to use the command

ethminer -G -F http://ethereumpool.co/?miner=[HASHRATE IN MHASH]@[ADDRESS]@[OPTIONAL RIG NAME]

Where the hash rate is the speed, the address is your Jaxx address and your rig name. So for me it looks like this:

ethminer -G -F http://ethereumpool.co/?miner=19@0x516976cE81751eBe077Ca01C57B97c9665b0e10b@LLG

Notice, no brackets. Also the -G means GPU. Remember, the address is your Jaxx address that you get from in-app. the ETH, not ETC If you have any issues comment at me.

  • 1
    What about for Yakkety onwards? There's no cpp-ethereum package since. – Oxwivi Jun 16 '17 at 12:35
  • 1
    What binary tarball download on their GitHub download page has the miner? – Oxwivi Jun 16 '17 at 12:36
  • The sudo apt-get install cpp-ethereum does not work - cpp-ethereum does not seem to exist... what's wrong? – Pixel Jun 29 '17 at 14:59
  • 1
    @Antinous You need to download the repo now that it's different from the original. github --> ethereum cpp – Liam Larsen Jun 29 '17 at 19:30
0

@liam W: The repository 'http://ppa.launchpad.net/ethereum/ethereum-qt/ubuntu zesty Release' does not have a Release file. N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use. N: See apt-secure(8) manpage for repository creation and user configuration details. E: Failed to fetch http://ppa.launchpad.net/ethereum/ethereum-qt/ubuntu/dists/zesty/main/binary-amd64/Packages 404 Not Found E: Some index files failed to download. They have been ignored, or old ones used instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.