0

I am creating a one private blockchain network over aws cloud with the help of 2 ubuntu instances. But I am unable to connect 2 nodes. Even I have checked it with ping with its internal Ips and both are working perfectly.

I have follow below command to do that,

sudo geth --datadir="ethdata" --verbosity 10 --ipcdisable --port 30303 --networkid 15 nodiscover console --allow-insecure-unlock --unlock "public address" --password password --http --http.port "8000" --http.addr "0.0.0.0" –http.corsdomain "*" --http.api "eth,net,web3,miner,debug,personal,rpc"

admin.addPeer("enode://7ac1...2337f8@xxx:xxx:xx:xxx:30303?discport=0")

Same Setup I have tried it over 2 different local system where I am able to connect it successfully.

Do anyone know about this ? is there any problem with ports over cloud or something else ? I have also tried it with different ports and network ids but could not able to connect it.

2
  • Does anything related to the connection appear in the output? Using sudo to run any server is generally not a good idea.
    – Ismael
    Jul 19 at 1:57
  • I have tried without sudo as well. It shows an error of "Dial error conn=staticdial err="i/o timeout" eth node:" Jul 21 at 0:16

1 Answer 1

1

I am able to resolve this issue by adding ports into my security group over cloud. Before, I had added only one port 8000 into the security group, but face the same problem. After that I have added all the mentioned ports that I have used (8000 and 30303) for both nodes. As a result I am able to connect it blockchain node. Also tested with mining where blocks are synchronizing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.