1

I have my private ethereum network. The way I started my geth:

geth --networkid 23422 --nodiscover --nat none --datadir="$datapath" --rpccorsdomain '*' --rpc --rpcaddr "localhost" --rpccorsdomain="*" --rpcport="8545"  --nodiscover --maxpeers=6 --bootnodes enode://$id@<ip>:<port> --autodag=false
echo 'miner.stopAutoDAG()'   | geth --datadir "$datapath" attach ipc:$datapath/geth.ipc console

My node does not do mining but it is connected the network. Blockchain is stop incrementing and halt on a number. My node gives following error:

I0314 09:32:13.387846 eth/backend.go:461] checking DAG (ethash dir: /root/.ethash)
I0314 19:32:13.388103 eth/backend.go:461] checking DAG (ethash dir: /root/.ethash)
I0315 05:32:13.388391 eth/backend.go:461] checking DAG (ethash dir: /root/.ethash)
I0315 15:32:13.388641 eth/backend.go:461] checking DAG (ethash dir: /root/.ethash)
I0316 01:32:13.388951 eth/backend.go:461] checking DAG (ethash dir: /root/.ethash)
I0316 11:32:13.389214 eth/backend.go:461] checking DAG (ethash dir: /root/.ethash)
I0316 21:32:13.389467 eth/backend.go:461] checking DAG (ethash dir: /root/.ethash)
I0317 07:32:13.389720 eth/backend.go:461] checking DAG (ethash dir: /root/.ethash)

I have to do sudo killall geth and restart my server. Then then node's blockchain sync with the original chain and everything is back to normal.

[Q] I have to check my node daily. How can I prevent this problem from happening? Could this problem related with --autodag=false flag?

Thank you for your valuable time and help.

2

I'm not entirely sure those messages are an indication of the real issue, but there's a potential problem with the flag you mention...


--autodag=false isn't doing what you think it's doing. It's actually doing the opposite.

The --autodag option doesn't take a value, so it can't be set to false. What you're doing by including it at all is actually the equivalent of setting it to true (because it will just ignore the =false part).

So by including it, you're asking the node to pregenerate the DAG, which isn't what you want, because you're not mining.

The miner.stopAutoDAG() is what you want to be using.

See this previous answer for more details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.