3

I set up an ethereum private chain for testing smart contracts a while back. Recently, I've been unable to deploy and interact with contracts successfully. Here is what used to work:

1) I created a chain in the command line:

geth --identity "testChain" --rpc --rpcport "8080" --rpccorsdomain "*" --datadir 
"C:\Users\<user_name>\Desktop\testChain" --port "30303" --nodiscover --rpcapi 
"db,eth,net,web3" --networkid 1999 init C:\Users\<user_name>\Desktop\customGenesis.json

Using this genesis:

{
    "nonce": "0x0000000000000042",     "timestamp": "0x0",
    "parentHash": "0x0000000000000000000000000000000000000000000000000000000000000000",
    "extraData": "0x0",     "gasLimit": "0x8000000",     "difficulty": "0x400",
    "mixhash": "0x0000000000000000000000000000000000000000000000000000000000000000",
    "coinbase": "0x3333333333333333333333333333333333333333",     "alloc": {    }
}

2) I run my chain:

geth --identity "testChain" --rpc --rpcport "8080" --rpccorsdomain "*" --datadir 
"C:\Users\<user_name>\Desktop\testChain" --port "30303" --nodiscover --rpcapi 
"db,eth,net,web3" --networkid 1999 console

3) Start ethereum wallet/mist and it automatically connects to my 'private-net'

4) Proceed to create an account, and start mining ether through geth attach

5) Navigate to 'Deploy Contracts' and paste my contract code. In this example, I am using the code provided by ethereum for issuing your own token.

6) Deploy contract.

7) Miner.start() and watch the 12 confirmations.

8) I am now able to view the currency I've created. I can also go manage the contract, as my account is the owner. Transfer assets, etc.

When I attempt this now, I run into problems at steps 6 and 8. In step 6, I sometimes get a gas limit error. I resolve this by exiting the wallet and trying again. When the contract is successfully deployed, I watch as the confirmations are completed. The problem is that my account never shows my ownership of 'shares' as the ethereum guide says it should. I am not able to transfer any of my 'shares', and there is no place to manage the contract.

Any thoughts?

| improve this question | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.