0

I have mew v2 json file. I want to convert this file to v3 utc via geth but I am getting an error, what should I do? i get the same error on windows 10 and linux (kali and ubuntu)

Geth Error: Fatal: Failed to load the private key: key file too short, want 64 hex characters

Method i tried: https://help.myetherwallet.com/en/articles/5449838-importing-a-v2-json-file

1 Answer 1

0

I am not completely clear on the initial direction of the question (convert to v3) however I did find this post on what seems to be a very similar issue with geth account import key file issue (from 2016). I have seen this issue in other areas regarding key import / export where possible "0x" stripping occurs. Here is the link to the "Go Ethereum" GitHub question:

https://github.com/ethereum/go-ethereum/issues/2503

To summarize for succinctness (and in the interest of disclosure and accreditation, here is a screenshot of the relevant comment)

Tayvano user comment snapshot

2
  • i tried but it opens new wallet
    – HKOX
    Commented Jun 13, 2022 at 15:17
  • So, you are no longer experiencing the issue referenced in the post above? I must still be unclear on your issue? It looks like MAYBE you are talking about an encrypted wallet stored in a JSON file? If that is your scenario, you need to re-ask the question properly or open a new question. Good luck...
    – RacerX
    Commented Jun 14, 2022 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.