0

I'm trying to install truffle on VS Code(in window 10) after installing node.js, npm and ganache. All the above three have been installed and worked but When I tried to install truffle in VS Code in terminal, these kinds of errors occurring again and again. What should I do? This is the first pic when I tried to install it

These two are the error pictures.

Error pic1

Error pic2

1 Answer 1

0

You can check the version of node and npm first. I had this error before, solving by changing npm version to v6 and node version to v16.

4
  • Emily Li, I have installed the latest version of node and npm. But this is still occurring.
    – Ali Hassan
    Jun 1, 2022 at 9:29
  • I mean lastest version may bring to these errors. You may try to downgrade it.
    – Emily Li
    Jun 1, 2022 at 9:38
  • Currently, my npm version is 8.5.5 and node is v16.15.0. Which version should I install.
    – Ali Hassan
    Jun 1, 2022 at 9:51
  • run npm install -g npm@6 in terminal will change the version of npm to v6
    – Emily Li
    Jun 1, 2022 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.