8

I first initiate the node using the genesis file with the command:

>geth init genesis.json

Then i start the blockchain network using the following command:

>geth --identity "node1" --rpc --rpcport "8001" --rpccorsdomain "*" --datadir "node1" --port "30304" --ipcapi "admin,db,eth,debug,miner,net,shh,txpool,personal,web3" --rpcapi "db,eth,net,web3" --autodag --networkid 123 --nat "any"

Then i open another command prompt and type

>geth attach 

I could've used 'console' but i wanted to monitor network log properly.

Now i created an account and gave the command:

>miner.start()

I0310 11:14:39.402000 eth/backend.go:454] Automatic pregeneration of ethash    
DAG ON (ethash dir: C:\Users\Rahul13615\AppData\Ethash)
I0310 11:14:39.403000 eth/backend.go:461] checking DAG (ethash dir:    
C:\Users\Rahul13615\AppData\Ethash)
I0310 11:14:39.404000 node/node.go:296] IPC endpoint opened:   
\\.\pipe\geth.ipc
I0310 11:14:39.407000 node/node.go:366] HTTP endpoint opened: 
http://localhost:8001
I0310 11:15:31.755000 miner/miner.go:119] Starting mining operation (CPU=4 
TOT=5)
I0310 11:15:31.756000 miner/worker.go:539] commit new work on block 1 with 0 
txs & 0 uncles. Took 1ms
I0310 11:15:31.757000 ethash.go:259] Generating DAG for epoch 0 (size 
1073739904)        
(0000000000000000000000000000000000000000000000000000000000000000)
I0310 11:15:32.717000 ethash.go:276] Done generating DAG for epoch 0, it  
took 961ms

After this no new blocks are commited. It just stopped or is running slow. How should i remedy this situation and make it run fast?

  • 1
    Have you tried sending transactions in this network? I think it stops when there are no new transactions to be mined.. – Max Binnewies Mar 10 '17 at 17:05
  • 1
    Try adding miner to rpcapi. – Joël Mar 15 '17 at 1:35
4

I assume you have started the miner using geth console. Why I'm saying this, I couldn't see --mine in your geth initiation command.

This will be the same again even though miner is started.

This happens because of the Machine RAM capability, Just try the eth.hashrate and eth.blockNumber. If both return zero, your machine is struggling with computation power.

So I tried with AWS instance with some good RAM capabilities, blocks were created immediately without any delay.

  • hi seetharaman..i am facing the exact same issue and my server machine.. configuration is 64GB RAM 128GB and 16CPU..what might be possible workarounds? – Alien Aug 28 '18 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.