0

When ever I run npx hardhat test I get this Error: missing argument: in Contract constructor (count=0, expectedCount=1, code=MISSING_ARGUMENT, version=contracts/5.6.2)

here is the main contract:

 contract KBMarket is ReentrancyGuard {

    using Counters for Counters.Counter;

    address payable owner;

    constructor() {
        owner = payable(msg.sender);
    }

and here is hardhat test.js:

describe("KBMarket", function () {
  it("Should Mint And Trade NFTs", async function () {
    const Market = await ethers.getContractFactory('KBMarket')
    const market = await Market.deploy()
    await market.deployed()
    const marketAddress = market.adderss
  }
}

Thanks in adavnce.

1
  • This is odd - have you tried deleting your cache and artifacts directories? May 30, 2022 at 9:03

1 Answer 1

1

I think you have a typo, is address instead of adderss

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.