2

I am using Parity/v1.5.0-unstable-a7037f8-20161126/x86_64-macos/rustc1.13.0 After I start the node, every page request in the browser fails with a "Server not found" error. As soon as I turn the Parity node my internet connection works again as expected.

These are the differences between netstat with parity running and parity off. Maybe this can help to detect if this is a port collision?

< tcp4       0      0  localhost.30303        localhost.62536        ESTABLISHED
< tcp4       0      0  localhost.62536        localhost.30303        ESTABLISHED
< tcp4       0      0  davids-mbp.local.62315 128.199.55.137.30303   ESTABLISHED
< tcp4       0      0  localhost.http-alt     localhost.61962        ESTABLISHED
< tcp4       0      0  localhost.61962        localhost.http-alt     ESTABLISHED
< tcp4       0      0  localhost.8180         *.*                    LISTEN     
< tcp4       0      0  localhost.http-alt     *.*                    LISTEN     
< tcp4       0      0  localhost.8545         *.*                    LISTEN     
< tcp4       0      0  *.30303                *.*                    LISTEN
---
> tcp4       0      0  davids-mbp.local.63153 52.222.157.6.https     ESTABLISHED
> tcp4       0      0  davids-mbp.local.62942 fra16s18-in-f14..https ESTABLISHED
59,61d51
< udp6       0      0  *.62792                *.*                               
< udp4       0      0  *.62792                *.*                               
< udp4       0      0  *.30303                *.*                               
134,138c124,127
< 90d5bc5341b2c3b5 stream      0      0                0 90d5bc5341b2c60d                0                0 /Library/Application Support/OpenVPN/sock/cliapi.sock
< 90d5bc5341b2c60d stream      0      0                0 90d5bc5341b2c3b5                0                0
< 90d5bc533cd467fd stream      0      0                0 90d5bc5341b2cf6d                0                0 /var/run/mDNSResponder
< 90d5bc5341b2cf6d stream      0      0                0 90d5bc533cd467fd                0                0
< 90d5bc5341b2d0fd stream      0      0 90d5bc5349c5d01d                0                0                0 /Users/uscreen/.parity/jsonrpc.ipc
---
> 90d5bc533cd467fd stream      0      0                0 90d5bc5341b2c60d                0                0 /var/run/mDNSResponder
> 90d5bc5341b2c60d stream      0      0                0 90d5bc533cd467fd                0                0
> 90d5bc5341b2d0fd stream      0      0                0 90d5bc5341b2cf6d                0                0 /Library/Application Support/OpenVPN/sock/cliapi.sock
> 90d5bc5341b2cf6d stream      0      0                0 90d5bc5341b2d0fd                0                0
  • Could be a port clash, depending on how you've got your browsing set up? Try giving Parity a different port using --dapps-port=<a_port_that_isn't_8080> e.g. --dapps-port=9090. – Richard Horrocks Mar 7 '17 at 18:27
  • I tried it like this parity ui --dapps-port=9090and like this parity ui --dapps-port 9090, but the port is not used. I still uses 8180. (I don't know why it is 8180 on my computer in all the tutorials it says that it should be 8080, maybe something else was running on 8080 when I first started parity). – David Albrecht Mar 7 '17 at 18:35
  • The Trusted UI server runs on port 8180, which is what you're seeing. – Richard Horrocks Mar 7 '17 at 18:42
  • 2
    Can you check if the problem persists when running parity --mode=offline as well? – todr Mar 13 '17 at 13:59
  • 1
    Does this also happen with the latest beta version 1.6.3? Could you also try to reset your settings by completely moving (not removing!) your parity folder from .local/share/ to somewhere else (and make sure you have backups of your keys), and start a clean instance without any parameters? – Waqar Lim Mar 22 '17 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.