3

There is a related question/answer from 5 years ago but back then the plugin only provided syntax highlighting.

Now, I know I can compile from the solidity file opened in IntelliJ, clicking on a play/run green arrow in the gutter.

My problem is: After I click on the arrow ("Run ContractName.functionName") I get a "Edit Configuration" window. with an error at the bottom ("Error: EVM is not configured"). I'm encouraged to click on a FIX button.

When I do that I get another window to configure Solidity. And here I can't introduce good values.

enter image description here

I don't know what to put on the EVM path. If I put the Solc path (/usr/local/bin or /usr/local/Cellar/solidity/0.8.14/bin) I get "No Solc installation found".

I don't know how to configure. I also have truffle and ganache installed but I preferred to compile directly from IntelliJ.

Thanks

1 Answer 1

0

It would be very useful to have such option but I am afraid it will not be possible (or at least not reasonable).
For me all options that are available under: Edit Configuration → Error: EVM is not configured → Fix lead in one way or another to EthereumJ related stuff.
Unfortunately EthereumJ on github is marked as deprecated and latest commit is from 20 May 2020.
I assume it may be possible to somehow build its codebase yourself and set EthereumJ VM path to generated artifact but still you would be ~2 years behind in terms of Ethereum evolution...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.