2

Whenever I run mist without any client, it launches a geth node in the background, connects to the network and syncs the blockchain.

If I have a geth node running and start mist, it detects the running node and directly connects to it.

But if I have both geth and eth --listen 30304 running at the same time, mist always tends to connect to the eth node. Why is it preferring eth?

How to tell mist to use geth rather than eth? Is it possible to control that behaviour?

  • The next release of Mist will have an option build in where you can select which client it should use, I'm not 100% sure this applies to both the build-in client and a self-started one however. – Maran Feb 13 '16 at 12:54
1

Fabian the Mist developer here.

I never tried your use case actually. But I assume eth is overwriting geth UNIX socket, as they both use the same socket path.

I can't control that behavior if am already running node and would consider this a very unusual edge case, running two nodes :)

Any suggestions welcome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.