0

for some reason I am having trouble upgrading the truffle solidity compiler version. truffle version --> Truffle v5.2.2 Solidity v0.5.16 When I uninstall and re-install truffle (npm uninstall -g truffle and npm install -g truffle) it is the same version. How do I use a more recent version of Solidity with Truffle? On windows 10.

1 Answer 1

0

I did find the correct method I believe is to modify the truffle-config.js. This works for me.

    }, //make sure you have the comma here 
    compilers: {
        solc: {
            version: "0.4.22", // ex:  "0.4.20". (Default: Truffle's installed solc)
        },
    },

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.