1

I have synchronizing geth node running on a Raspberry Pi Model B (8 GB RAM) with an external 1TB SSD attached via USB-3 running Arch Linux.

I've been "synchronizing" for about 5 days or so now. My "currentBlock" is always fluctuating between 50-100 blocks away from "highestBlock" count. I'm using snap sync and, looking at the docs, it seems to be normal for there to be a period of time where the node doesn't quite reach the highestBlock count but eventually does.

Why is it taking this long? Here's the command I've used to start geth:

geth --datadir geth --signer=geth/clef/clef.ipc --mainnet --syncmode snap --cache 4096 --mine

As you'll likely see, I'm running clef as the address signer and have had no issues with that thus far.

Is it possible that the Rpi 4 doesn't have the necessary hardware power to sync a node? Have I screwed something up?

EDIT: My geth datadir is approximately 566GB and the download seems to have slowed down considerably at this point as well.

Thanks!

1 Answer 1

3

The solution was simply more time. The resources at my disposal claimed that an RPi would be able to sync in a matter of 2-3 days with a speedy internet connection. For me, it took about a week.

I am fully synced up now!

1
  • If you are in a hurry, you can use the --syncmode "light" option. Apr 20, 2022 at 4:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.