2

I have a Private Ethereum Network. As a node I connected to the network as a peer. When I submit a transaction from my node, it won't fall into mining pool, in case I start mining on my node.

When I start mining on my node, the transaction get eventually mined.[1]

Start mining:

The transaction that has deployed the contract needs to be verified by the network, if we are running a private chain with a single node we will need to mine the transaction. [1]

[Q] If we are running a private chain with multiple nodes as a connected node still do I need to mine the transaction? As I understand each node is forced to do mining for their transactions to get into mining pool. Is there any way to push my transactions into mining pool without start mining?

Thank you for your valuable time and help.

[1] https://ethereum.stackexchange.com/a/9316/4575

3

No.

The important thing is someone is mining. If the private chain is working properly, then it's a work-alike for the real network.

Anyone with a node can submit a transaction. The transaction takes effect when a miner includes it in a block. Nodes are informed about those blocks.

So, the important thing is someone on the network is discovering blocks.

Hope it helps.

  • I was thinking like you as well, but on my case it did not work. There is someone who mines and private chain is working properly in my network. No matter I did from my connected node, I was not able to submit my transactions without starting miner within the connected node. Does all the miners on the network discover the blocks?@RobHitchens. – alper Feb 27 '17 at 8:02
  • 1
    In theory, all nodes verify but only miners actively try to find block solutions. Your comment reminds me of some posts I've seen about various problems with private chains, some quite strange. This reminds me other posts over the past two months. It might take some digging, but I think you'll find people with same/similar issues and some interesting conclusions. – Rob Hitchens - B9lab Feb 27 '17 at 8:20
  • 1
    I'm not sure this is related but, in case it helps. github.com/ethereum/go-ethereum/issues/2769 – Rob Hitchens - B9lab Feb 27 '17 at 10:05
  • The link you guided solved my problem. My node connecting to the network with --nodiscover flag, when I removed it, the problem has been solved. @RobHitchens – alper Feb 27 '17 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.