1

I was trying to launch Mist after a long time and I was hit bye error popup stating:

Couldn't connect to node? See logs for more: Node Type: geth Network: main Platform: linux (Architecture x64)

..flag provided but not defined:-support-dao-fork

enter image description here

Have never faced the issue. I have been using the same wallet (v0.8.6).

1

Upgrade Ethereum Wallet to 0.8.9. Ethereum Wallet 0.8.9 will download the correct version of geth - see https://github.com/ethereum/mist/blob/v0.8.9/clientBinaries.json .

The newer versions of geth have removed the -support-dao-fork command line option.

  • Thanks. I'll try that. But I am concerned about How I was able to launch the same wallet with including any additional command line option and it was working fab. Now, what's the issue? – Prashant Prabhakar Singh Feb 27 '17 at 5:43
  • You probably upgraded your version of geth and the newer version had the -support-dao-fork removed. When you run the old version of Ethereum Wallet, it passes this -support-dao-fork parameter to geth and it causes an error when starting geth. – The Officious BokkyPooBah Feb 27 '17 at 5:56
  • 1
    I have not downloaded geth explicitly. I have geth1.4.18 that came along with Ethereum-wallet-0.8.6. So was not expecting such behaviour. – Prashant Prabhakar Singh Feb 27 '17 at 6:11
0

Removing all the files from C:\Users\Your name\AppData\Roaming\Ethereum\geth\chaindata and/or from C:\Users\Your name\AppData\Roaming\Ethereum\geth\lightchaindata and starting it again solved the problem for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.