1

contract deployment

I get the error message "Intrinsic gas too low" when trying to deploy my contract on the testnet. Pic is my screenshot. I had set the fee slider to max (1.005 Ether). My account balance is 5.9 ether.

  • A bit of a hint here: ethereum.stackexchange.com/questions/1570/…. If I'm not mistaken, 5.5M gas is over the block gas limit; just plain too big for the network. Possibly the message is a little misleading and the truth of it is the contract is just too big. – Rob Hitchens - B9lab Feb 16 '17 at 22:25
  • I saw that question but it was about calling a function of a contract that has already been deployed, so I thought my case might be different. So there's a maximum size for contracts? I thought I could adjust gas parameters in geth to accommodate a large contract. – teeyoovee Feb 16 '17 at 23:23
  • I found you a pretty good description of the block gas limit over here: bitcoin.stackexchange.com/questions/39132/… Suffice it to say that it does exist, it can vary over time, and it's a property of a block in the network. It's possible to fiddle with that parameter in various tools and private chain arrangements, but ultimately, the figure that matters is the network's limit where you're sending your transaction because it's a hard lime of mining power you can summon from the network. – Rob Hitchens - B9lab Feb 16 '17 at 23:48
  • hard "limit" not "lime" ... sheesh – Rob Hitchens - B9lab Feb 18 '17 at 10:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.