1

I have been trying to get a windows instance of a container with geth client installed within it. Following the link below, I have been successfully able to use chocolatey to get go, git, etc. https://github.com/ethereum/go-ethereum/wiki/Installation-instructions-for-Windows Particularly in the last step of the installation:

C:\Users\xxx\src\github.com\ethereum\go-ethereum> go install -v ./...

I have been seeing the following issues:

open Documents and Settings: Access is denied
open Program Data/: Access is denied
go\src\golang.org\x\net\html\charset\charset.go:20:2: cannot find package "..."
....(GOPATH)
....(GOROOT)
can't load package: package ./tools/go/test found packages...   

As an alternative I tried attaching to the container and running the command manually and although I dont see the permission denied errors, the errors around finding and loading necessary packages still exist. Any suggestions would be immensely helpful

  • Could be a silly suggestion, but have you tried running the your installation commands in administrator mode CMD? – Samuel Hawksby-Robinson Feb 15 '17 at 20:19
  • Yea! Although the initial issue around denied access resolved, the remaining issues still continued to remain – skarred14 Feb 16 '17 at 3:04
  • As the assumption, maybe the problem, that path contains white spaces in the name? Did you try without whitespaces? – Viktor Baranov Feb 16 '17 at 21:07
  • Possibly! Windows Go space instructions in the link below are what I followed - not sure if this has a whitespace issue – skarred14 Feb 20 '17 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.