2

I've been having issues trying to get a solidity compiler in both my windows and linux clients.
I've tried a few times - following instructions from answers from this community (some links are dead), repeating installations of geth with full dev options, you name it.

In the end of the day, when I run eth.getCompilers() it comes out null...

Ideally, I would be able to install on a linux server which is only connected to an intranet (I have geth running there, installed manually). If that is not possible, I'll be glad if I can find a solc.exe that actually works, so I can run contracts trough the CLI.

Thanks for any help,
MB

  • It used to be the case that empty output from eth.getCompilers() was a red herring, and that it probably was actually installed. Have you tried ignoring this, and attempted to compile anything? (See this thread for a similar discussion: ethereum.stackexchange.com/a/5841/52) – Richard Horrocks Feb 14 '17 at 16:51
  • Yes. I've tried compiling some small contracts with little success. I've also tried adding a new system variable for path, but there was just no solc.exe (I'm speaking only of the windows client... baby steps :P) to direct it to... – mik Feb 15 '17 at 8:16
4

If you have solidity compiler installed then you can try following:

  • Get the path to the client using: which solc (for linux)
  • Set path in geth console using: admin.setSolc("path/to/solc")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.