5

I am completely new to the mining world and i wanted to try it once. I have a Sapphire R9 290X.

I followed all the steps to start mining. Aftert typing in :"geth --rpc --fast --cache=1024" my computer is syncing the last 5 days. My computer crashed 2 times since then, so i reopenend it and it continue loading. Right now my chaindata folder is 56,3GB and the sync is still going on.

my terminal has lines like:

I0213 19:30:51.409306 core/blockchain.go:1001] imported 3 block(s) (0 queued 0 ignored) including 49 txs in 16.8458156s. #2431234 [c2eddc7d / 9c8044f2]

I0213 19:31:06.445217 core/blockchain.go:1001] imported 4 block(s) (0 queued 0 ignored) including 58 txs in 15.0359109s. #2431238 [9c8044f2 / 0dc91408]

I0213 19:31:20.546331 core/blockchain.go:1001] imported 12 block(s) (0 queued 0 ignored) including 60 txs in 14.1011141s. #2431250 [0dc91408 / 80bd5e52]

Where is the end?

1

Unfortunately, the latest block (as of this writing) is #3177341. You're most of the way there, but there's still much to go.

Yes, this is absurd. Work is being done to make this less absurd. Two simple options (aside from just waiting) are

  1. Use parity, with parity --warp. It's incredibly fast.
  2. Try a mining pool, which does not require you to personally sync. You would need some sort of synced client eventually to see your payouts.

Hope that helps!

  • Will parity load everything again and save it somewhere else? or is it using the same directory like geth? The chaindata folder – hatemjapo Feb 13 '17 at 22:38
  • I believe parity uses a separate directory, so not geth's chaindata folder. You'd have to start from scratch to use warp sync anyway (but it is much faster.) – Matthew Schmidt Feb 13 '17 at 23:04
  • @hatemjapo Have you found the right way forward ? I am interested in importing the full block data for analysis. – Khwaishien Mar 10 '17 at 11:37
2

My computer crashed 2 times

Since your computer crashed, you are no longer fast syncing. So as crazy as it may sound, deleting the blockchain with geth removedb and restarting geth --rpc --fast --cache=1024 should be faster (try to ensure computer doesn't crash again). You're currently normal syncing through some "state-bloat blocks" which takes a lot of time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.