After cloning ethereum classic repo, running "make geth" command leads to the following error:

cannot load hash/maphash: malformed module path "hash/maphash": missing dot in first path element

I also tried with the last commit of their release version but I get the same issue!

Does it mean they don't test their releases? How to fix it?

Thanks for help!!!

  • Are you running Linux or another OS ?
    – hroussille
    Feb 3, 2022 at 21:51
  • I'm running Ubuntu 20
    – Kevin Wad
    Feb 3, 2022 at 21:53
  • @hroussille thanks for help if you have an idea please let me know. I'm on a digital ocean ubuntu 20.04
    – Kevin Wad
    Feb 3, 2022 at 21:59
  • @hroussille going back to this release solved this issue. github.com/etclabscore/core-geth/releases/tag/v1.12.0
    – Kevin Wad
    Feb 3, 2022 at 22:08
  • 1
    Latest release (v1.10.15 commit 8be800ffa9c4992666e2620e0ab4725a1a83352b) builds fine for me (I can only test on windows right now :/). The master branch is not stable, maybe that's what you used ? They do test their release, don't worry. Try again after running git checkout v1.10.15
    – hroussille
    Feb 3, 2022 at 22:09


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.