3

In the geth console contract compiled fine, but it giving an error like this when ever I am going to deploy, is there any dependencies there?

var greeterContract = web3.eth.contract(greeterCompiled.greeter.info.abiDefinition);

Type Error: Cannot access member ‘info’ of undefined at :1:41

even though I changed greeterContract name also, I am getting same error like Type error: ...<>:1:23


var greeter = greeterContract.new(_greeting,{from:web3.eth.accounts[0],data: greeterCompiled[":greeter"].code, gas: 1000000}, function(e, contract) {if (!e) {if (!contract.address) { console.log("Contract transaction send: TransactionHash: " + contract.transactionHash + " waiting to be mined...");} else { console.log("Contract mined! Address: " + contract.address); console.log(contract);} }})

Type Error: Type Error: Cannot access member ‘new’ of undefined at :1:15

marked as duplicate by Rob Hitchens - B9lab, niksmac, Waqar Lim Feb 10 '17 at 10:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This is not a duplicate. Solidity is broken recently. I don't have the <stdin> but still get the error. So the related question is not the same. – Jus12 Feb 12 '17 at 22:12