1

I'm struggling with decoding the input data from transaction, have tried already everything that I found in similar topics here but all I can retrieve is:

{
  "method": null,
  "types": [],
  "inputs": [],
  "names": []
}

Transaction ID is 0x4e12c7c79be4b6f33ed271db399a354fd8016952c83df186985a7ff1103f2187.

That's how I try to do it:

  1. Go to https://etherscan.io/tx/0x4e12c7c79be4b6f33ed271db399a354fd8016952c83df186985a7ff1103f2187 and copy the contents of "Input Data" field - this is what I need to decode.
  2. "Interacted With (To)" field leads me to contract ID 0x9757F2d2b135150BBeb65308D4a91804107cd8D6 which is proxy, so I go to "Contract" tab, then "Read as Proxy" and there it points me to another contract 0xe441aefa11e775803dd47f5e949886b71a4b312d which seems to be a final exchange contract.
  3. Open the final contract's page https://etherscan.io/address/0xe441aefa11e775803dd47f5e949886b71a4b312d#code, scroll to the bottom and copy the contents of "Contract ABI" field.
  4. Open https://lab.miguelmota.com/ethereum-input-data-decoder/example/, paste field values retrieved on previous steps ("ABI" & "Input Data") and then I receive the json I posted above as the result of decoding.

When trying to use another online tool or do it through the code (tried "ethereum-input-data-decoder" node library), I got the similar result. Also, tried to do it over the ABI of proxy contract itself (without going to the underlying proxied contract) - result is similar.

I would be very happy if someone code point me at the place where I'm doing something wrong. Thanks!

Here's my screen recording showing how I'm trying to do it.

4
  • I think the problem is in the decoders not supporting the abi.
    – Ismael
    Commented Jan 27, 2022 at 5:31
  • Thanks! Could you please give more information on it? Are there different ABI versions? Did not found anything about it in google. It's looking weird since many different tools & libs are giving similar result while they are looking working with ABI functionality out of the box, and there's nothing said about supporting or not supporting the abi. Commented Jan 28, 2022 at 20:52
  • With solc 0.8 ABI coder v2 is activated by default. docs.soliditylang.org/en/v0.8.11/080-breaking-changes.html. I don't remember exactly but I think the v2 supports array of structs.
    – Ismael
    Commented Jan 31, 2022 at 15:21
  • Im having same issue, did you find a solution ?
    – ezIlj
    Commented Dec 6, 2022 at 14:44

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.