0

I have a YAML file configured but when I compile the code, it does not create dependencies directory and neither the json files. The sources I import mentions: File import callback not supported. Any suggestions?

enter image description here

enter image description here

1

1 Answer 1

1

You should first check if the package is correctly installed from brownie.config.yaml using next command

brownie pm list

If the package is missing, you need to install the package first using next command:

brownie pm install smartcontractkit/[email protected]  

Then compile the project again (additionally, you can use optional -a flag to force recompile all contracts)

brownie compile
2
  • I ran brownie pm list and I do have the package installed. Just as before, it says in the terminal that the project has been compiled. Build artifacts saved at XXX. But still the JSON file is not showing in the dependencies directory.
    – Daniel
    Jan 24, 2022 at 23:01
  • AggregatorV3Interface.json should be in the dependencies folder once you reference it in your smart contract (for example as a state variable AggregatorV3Interface internal priceFeed;). To "shut down" File import callback not supported VSCode error, check this question
    – Andrej
    Jan 25, 2022 at 12:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.