0

I am trying to use https://github.com/digitaldonkey/ethereum-php to build an api tool for scanning smart contracts for vulnerbilities.

Ref link: https://ethereum-php.org/dev/

My doubt it is possible to do that? I have various security tool like mythrill (https://github.com/ConsenSys/mythril), Securify (https://github.com/eth-sri/securify2). But those are built on python. I need something to be developed on php or javascript. Kindly pour some ideas on this. Is it possible to scan smart contracts for vulnerabilities with php?

2
  • It should be possible, PHP is a general purpose computer language. Although I'd say it is impractical having mythril and several other tools rewriting them in PHP isn't very interesting.
    – Ismael
    Commented Jan 27, 2022 at 5:19
  • @Ismael Ok, Thanks for the update Commented Jan 27, 2022 at 5:53

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.