1

I got stuck with the error:

ERROR: NetworkId mismatch: 3 (!= 1100)

Running geth node with parameters:

geth --rpccorsdomain "*" --ipcapi "admin,eth,miner" --rpcapi "eth,web3" --networkid 1100 --maxpeers 5 --etherbase "xxxxx(hidden)" --verbosity 3 --minerthreads 1 console 

And then run swarm with:

$GOPATH/bin/swarm --bzzaccount 41bad198c4504045f3dfa54902e08384e9162b04 --datadir /home/ubuntu/.ethereum --ethapi /home/ubuntu/.ethereum/geth.ipc --verbosity 3 --maxpeers 5 --bzznetworkid 1100

After all I'm getting the logs:

I0206 12:20:28.403510 errs/errors.go:86] [BZZ] ERROR: NetworkId mismatch: 3 (!= 1100)

Where could that error come from?

  • Have you considered to run geth with the --datadir flag? It looks like it uses the default existing testnet configuration somehow (which is ID #3). – Waqar Lim Feb 14 '17 at 9:31
  • @Anatolii: Did you find the solution for this? I have the same issue – Hoang Trinh Dec 18 '18 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.