0

I connected my truffle project to the ganache network. Also I added ganache network into the metamask. After deploying erc20 contract to ganache, I can see my account's token balance on truffle console but cannot import the token on metamask. All metamask, ganache and truffle accounts are the same and eth balances are synched but somehow metamask cannot recognize deployed contract on the network.

my ganache port is 127.0.0.1:7545 token deployed network is also 127.0.0.1.7545 metamask ganache network is 127.0.0.1:7545 chainId: 1337

Appreciate any help.enter image description here enter image description here enter image description here

3
  • You probably need to add the token by yourself into metamask. There is a button called import Token
    – Majd TL
    Jan 14 at 17:27
  • Hi SalihCemilCetin! Welcome to Ethereum Stackexchange! Are you sure it is a fully compliant ERC-20? From the log it appears you deployed Truffle's Metacoin, Can you add the token code to the question?
    – Ismael
    Jan 15 at 17:53
  • Hi, thank you for welcome. First I tried with a basic erc20 token but it didn't work, then I try to use a working example but also it didn't work. Jan 15 at 20:31

2 Answers 2

0

You have to add your token manually in metamask

In the assets tab, at the end you will find the option "Import tokens"

enter image description here

then the window will appear where you can add the address of your token

enter image description here

1
  • I did the same process. Migrate the token to network 127.0.0.1:7545 which is ganache running on. I import also ganache accounts to metamask and see the ether balance is synced with ganache. After migrating contract, I go and import the token by its contract address but metamask cannot find the token. I add manually by typing decimals and symbol, and my account token balance is zero. But I can see balance in the truffle console Jan 14 at 20:46
0

I managed to fix it. My truffle project somehow wasn't able to connect to ganache network even I type connection info in truffle-config (I still don't know why). But after I restart ganache and in workspace creation, I choose my project's truffle-config and click add project button. Then I compile and migrate again in 'truffle console' but not 'truffle develop'. After these, it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.