1

I am playing around with Ethereum testnet.

I created an account at https://test.ether.camp/. I received free Ether and sent 1 Ether to an account address on my local geth client, which I created on my Macbook with the following commands:

geth --fast --cache=2048 --testnet console

(..... after it finished synchronizing .....)

personal.newAccount("###_my_passphrase_###")

This is the only account I have here.

The EtherCamp account address is 0xd2812d264e9895e8c31122aaffedb6f444c1a2d0. The transaction is completed successfully.

However, I only see '0' when asking for my balance:

web3.fromWei(eth.getBalance(eth.coinbase), "ether") web3.fromWei(eth.getBalance(web3.eth.accounts[0]), "ether")

Now, I started mining for ~15 minutes ago with

miner.start(2)

It still shows '0' even though I read that you should get some Ether relative quickly.

Therefore, I wonder If I check the wrong balance !? Or does my local geth client use another testnet than EtherCamp?

UPDATE: I found out that I am on the right testnet, because I also sent me one Ether via http://faucet.ropsten.be:3001/. This worked and after a few minutes I received the one Ether. My balance is 1 now. I doublechecked via EtherScan that this is the Ether from faucet: https://testnet.etherscan.io/tx/0x4dee8036ac3df3d6ab68126d109a6df3de54aff674230bd4e2dd605acb37e890 Therefore, I really wonder why I do not get my Ether from EtherCamp (and also none via mining yet).

Thanks for help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.