I followed this answer to connect Mist to testrpc: https://ethereum.stackexchange.com/a/10109/5995

The command to start Mist with arguments doesn't work on OS X so I tried this instead, which doesn't work either (Mist opens on testnet): open -a /Applications/Mist.app/Contents/MacOS/Mist --args rpc localhost:8545

How can I get this working?

4 Answers 4


This one worked straight away for me:

$ /Applications/Mist.app/Contents/MacOS/Mist --rpc http://localhost:8545
  • 2
    Does no longer work as mist has switched to IPC. Work in progress for supporting IPC: github.com/ethereumjs/testrpc/pull/261 May 30, 2017 at 6:57
  • 1
    @RolandKofler it works currently :) It gives a warning that it's insecure, but who cares it is testrpc.
    – EralpB
    Sep 16, 2017 at 10:39

As for me (Using Ethereum client) macOS (Aug 2017)

"/Applications/Ethereum Wallet.app/Contents/MacOS/Ethereum Wallet" --rpc http://localhost:8545

This is correct command for the latest mist 0.9.3 -

open -a /Applications/Mist.app --args --rpc <path/to/your/geth.ipc>


this work for me

open -a /Applications/Mist.app --args --rpc < path to geth.ipc >

im using ios mojave

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.