1

Hi not needing this now but I think the docs needs some work to produce a start to end flow of all the code as the parts and pieces don't really work together currently.

  1. I start with the below from safe-core-sdk

import { SafeTransactionDataPartial } from '@gnosis.pm/safe-core-sdk-types'

const transaction: SafeTransactionDataPartial = { to: '0x', value: '<eth_value_in_wei>', data: '0x' } const safeTransaction = await safeSdk.createTransaction(transaction) I can sign the txns and all fined.

  1. I follow your code as below but it returns 404 as below. Executing Transaction

const apiTx: SafeMultisigTransactionResponse = await safeService.getTransaction('')

On https://safe-transaction.rinkeby.gnosis.io/, I can see 2 txns with safe address 0x5dAFC062A69F3646397CdF1a175E90666b8AEFF3 using the /safes/{address}/all-transactions/ but these don't appear with /safes/{address}/multisig-transactions/.

Thanks for the help

1 Answer 1

0

You can find the documentation/ guide for this on the safe-core-sdk repo

Also the all-transactions endpoint only returns transactions with that have a confirmation from an owner, to avoid malicious spamming of transactions.

On the swagger of the transaction service it says:

Multisig Transactions for a Safe. tx_type=MULTISIG_TRANSACTION. If the query parameter queued=False is
set only the transactions with safe nonce < current Safe nonce will be displayed. By default, only the
trusted transactions will be displayed (transactions indexed, with at least one confirmation or proposed
by a delegate). If you need that behaviour to be disabled set the query parameter trusted=False

The same applies to the official Safe interface, it will always only return transactions that have at least one confirmation from an owner or a delegate of an owner.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.