I have created the following transaction in the Gnosis Safe Service: https://gnosis-safe.io/app/rin:0x62c1bC4236F7df56D7475a1B95463236e3d85947/transactions/queue

This was created using the SDK:

const safeTransaction = await safe.createTransaction({
        to: toAddress,
        value: ethers.utils.parseEther(String(amount)).toString(),
        data: `0x${uuid.replace(/-/g, "")}`,

const safeTxHash = await safe.getTransactionHash(safeTransaction);
await safeService.proposeTransaction({

2/2 signers have confirmed the transaction in Gnosis Safe. When trying to execute the transaction I get the following error message: This transaction will most likely fail. To save gas costs, avoid creating the transaction.

And when proceeding anyway, incl manually setting the gas limit, I get the GS013 error: Safe transaction failed when gasPrice and safeTxGas were 0 Transaction: https://rinkeby.etherscan.io/tx/0x2f0e6b7b0dbbc14d01c2927397fbf066ab0aaede6fcdee6acd333c6b82a1ee3d

Where do I make sure that gasPrice and safeTxGas aren't 0?

1 Answer 1


The problem here is not the safeTxGas and gasPrice. If you would set these value, the internal Safe transaction would still fail.

Looking at your transaction I can see that you try to transfer 8000000000000000 WEI which amounts to 0.008 ETH but the Safe only has 0.002999 ETH, therefore the transaction fails because of insufficient funds.

More information on the safeTxGas and gasPrice issue can be found here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.