2

I am following Patrick Collin's smart contract course on youtube and am stuck at the 2hr 46min mark (FundMe.sol) ETH/USD Chainlink price feed on rinkeby.

The code from the video compiles ok but when i try to deploy to rinkeby, my metamask does not pop up and i get the following error:

"creation of FundMe errored: [TIMEOUT] Timeout for call deployMetadataOf from udapp"

Here is the code I am using in REMIX.

// SPDX-License-Identifier: MIT

pragma solidity ^0.6;

import "@chainlink/contracts/src/v0.6/interfaces/AggregatorV3Interface.sol";

 
contract FundMe {

    mapping(address => uint256) public addressToAmountFunded;

    function fund() public payable {
        addressToAmountFunded[msg.sender] += msg.value;
        // what the ETH -> USD conversion rate  
    }

    function getVersion() public view returns (uint256){
        AggregatorV3Interface priceFeed = AggregatorV3Interface(0x8A753747A1Fa494EC906cE90E9f37563A8AF630e);
        return priceFeed.version();
    }
}

To try and fix the problem I started over creating FundMe.sol from the beginning and changed versions to "@chainlink/contracts/src/v0.8/interfaces/AggregatorV3Interface.sol" incase the one in the video was no longer correct. I also tried to copy paste the entire code instead of just importing.

4
  • Hi @JMG, what IDE or software are you using when creating and compiling your contract? Are you using remix, VS Code etc? Dec 17 '21 at 22:56
  • Hi @JMG I just tried your code in remix and I was able to deploy on Rinkeby. Here are the steps, please follow and let me know how you go: 1 - paste code above in remix 2 - compile code 3 - go to remix run tab 4 - change contract drop down to 'FundMe' 5 - ensure environment drop down is set to Injected web3, and that your metamask is connected to Rinkeby 6 - Press the deploy button Dec 19 '21 at 22:30
  • Hello @Harry, it worked! thanks, I think i must have had my metamask connected to kovan from something earlier in the course.
    – JMG
    Dec 19 '21 at 23:15
  • Hmm.. wondering what this issue was. If someone can reproduce and come to a conclusion as an answer that would be awesome. Dec 21 '21 at 23:42
0

I had the same problem and i just deactivated my brave shield/ ad blocker and it worked !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.