1

I tried installing ganache-cli with yarn. Even though yarn has successfully installed ganache-cli, I bash can't find the ganache-cli.

smakbar@OMEN:~/cryptoCurrencies/web3$ yarn global add ganache-cli
yarn global v1.22.17
[1/4] Resolving packages...
[2/4] Fetching packages...
[3/4] Linking dependencies...
[4/4] Building fresh packages...

success Installed "[email protected]" with binaries:
      - ganache-cli
Done in 1.66s.
smakbar@OMEN:~/cryptoCurrencies/web3$ ganache-cli
ganache-cli: command not found
1
  • I am having the exact same problem. Were you able to solve it? If yes how did you do it?
    – Ararao
    Jan 4, 2022 at 16:28

2 Answers 2

1

I was facing same problem it is solved by

npm install -g ganache-cli
1
  • This worked for me thanks. But why did the yarn install not work and this does??? Is anyone else as annoyed as I am re: all these package managers that fail to do their job? I've been having so many issues for months w/ truffle, npm, nodjs, yarn, blahblah blah. Seem like the whole world is broken when it comes to software installs.
    – JDOaktown
    Feb 24, 2022 at 20:19
0

Running ganache with sudo worked for me. Try the following

sudo yarn global add ganache
1
  • 1
    using sudo as a fix is generally not a good idea. Jun 23, 2022 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.