0

I'm receiving an internal error when attempting to place an order on the Avalanche chain.

Url: https://api.0x.org/orderbook/v1/order

Error:

{
    "code": 100,
    "reason": "Validation Failed",
    "validationErrors": [
        {
            "code": 1008,
            "field": "signedOrder[0]",
            "reason": "Internal error"
        }
    ]
}

Request Body:

{
    "maker": "0x1916E7D0c34f47Af1cD68e4659c8B9d07cE10818",
    "taker": "0x0000000000000000000000000000000000000000",
    "makerToken": "0xb31f66aa3c1e785363f0875a1b74e27b85fd66c7",
    "takerToken": "0x130966628846bfd36ff31a822705796e8cb8c18d",
    "makerAmount": "10000000000000000",
    "takerAmount": "1077120981937866955",
    "pool": "0x0000000000000000000000000000000000000000000000000000000000000000",
    "expiry": "1638595465000",
    "salt": "2752094376750492926844965905320507011598275560670346196138937898764349624882",
    "chainId": 43114,
    "verifyingContract": "0xdef1c0ded9bec7f1a1670819833240f027b25eff",
    "takerTokenFeeAmount": "0",
    "sender": "0x0000000000000000000000000000000000000000",
    "feeRecipient": "0x0000000000000000000000000000000000000000",
    "signature": {
        "v": 27,
        "r": "0x123456789",
        "s": "0x123456789",
        "signatureType": 2
    }
}

The signature was taken from the entire request body and then appended to the json object. I've tried using the avalanche subdomain but that didn't work for me either. The majority of the data in the request body was populated using the response from swap endpoint.

Any ideas? All help is appreciated.

1 Answer 1

0

We have not yet enabled Limit orders on Avalanche chain. In the future when we do it will require the avalanche subdomain as you tried. https://avalanche.api.0x.org/orderbook/v1/order

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.