3

I wanted check if I can connect to a remote server to get some information and send a transaction.

First I checked the connection with this :

curl -X POST --data '{"jsonrpc":"2.0","method":"eth_syncing","params":[],"id":1} http://xxx.xxxx.xxx.xxx:8545

But I've this error :

curl: (3) [globbing] nested brace in column 50
curl: (3) [globbing] nested brace in column 50
curl: (3) [globbing] nested brace in column 50
Provided Host header is not whitelisted.

What doest it mean? What can I do to resolve it?

1
  • It looks to me like you're missing the closing single quote after the closing bracket. Commented Jan 18, 2017 at 18:58

2 Answers 2

3

Globbing

Turn globbing off with -g and tell curl about the content type being JSON:

curl -g -X POST -H 'Content-Type: application/json' -H 'Accept: application/json' --data '{"jsonrpc":"2.0","method":"eth_syncing","params":[],"id":1}' http://xxx.xxxx.xxx.xxx:8545

Also there is a ' missing after the last bracket before the URL parameter.

This is working for me with parity on localhost:

 0 ✓ user@alcor ~ $ curl -g -X POST -H 'Content-Type: application/json' -H 'Accept: application/json' --data '{"jsonrpc":"2.0","method":"eth_syncing","params":[],"id":1}' localhost:8545
{"jsonrpc":"2.0","result":{"blockGap":null,"currentBlock":"0x2e0567","highestBlock":"0x2df992","startingBlock":"0x2df992","warpChunksAmount":null,"warpChunksProcessed":null},"id":1}

Whitelisting

You need to relaunch the remote host's with a parameter that allows remote connections, e.g. --jsonrpc-hosts="all" for parity. For geth, I'm unsure, try --rpcaddr 0.0.0.0.

5
  • I tried your solution, I just remplace localhost by my host, but I always have the same error!
    – wxcvbn
    Commented Jan 18, 2017 at 13:38
  • Updated the answer concerning the whitelisting issue.
    – q9f
    Commented Jan 18, 2017 at 13:40
  • 1
    Okay I just add jsonrps-hosts = "all"and it's working perfectly!! Thanks a lot!!!!!
    – wxcvbn
    Commented Jan 18, 2017 at 13:46
  • I've a other question, I've a time out error when I tried to do sendTransactioncommand Have you any idea to resolve this problem?
    – wxcvbn
    Commented Jan 18, 2017 at 13:48
  • If you have another question, please ask it by clicking the Ask Question button, will be hard to nail down your problem in comments here. Also read my post on Monero meta about follow-up questions. :-)
    – q9f
    Commented Jan 18, 2017 at 13:53
1

Accessing UI remotely has been recently described on Parity Wiki: https://github.com/ethcore/parity/wiki/UI-Remote-Access

Recommended method is to use SSH and port-forwarding:

$ ssh -L 8080:127.0.0.1:8080 -L 8180:127.0.0.1:8180 -L 8545:127.0.0.1:8545 <user>@<host> -vv

it doesn't require any special flags and it provides the best security.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.