0

I launched a private network by using geth --datadir data/node1 --http --dev --http.corsdomain "*" --http.api web3,eth,debug,personal,net,miner --allow-insecure-unlock --mine command.

I am able to attach to it geth attach http://localhost:8545

but the balance of the default account is only 1.15 ether:

> eth.getBalance(eth.accounts[0]) 1.15792089237316195423570985008687907853269984665640564039457582226449518702905e+77

I'd like to give it more ethers so I run:

> miner.start()
null

And I can see there is a warn in the node log: WARN [11-27|21:54:32.983] Block sealing failed err="sealing paused while waiting for transactions".

I wonder what the issue could be?

1
  • I think geth launch in dev mode (parameter --dev) only mines on demand, when there are pending transactions.
    – Ismael
    Nov 27 '21 at 23:47
0

To start mining do miner.start(1)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.