0

I'm trying to create a fork of Ohm to simply run in a local environment for now. I'm slowly teaching myself how to code in solidity and have a few basic web apps under my belt.

I'm running into an issue whenever I try to run the yarn, then yarn start commands.

I'm getting the follow errors, I've tried countless debugging, made sure I had all the depencies, re-downloaded the fork ( git clone https://github.com/OlympusDAO/olympusdao.git )

Any suggestions as to what might be causing these issues?

When running yarn:

-'[' is not recognized as an internal or external command

When running yarn start:

'react-scripts' is not recognized as an internal or external command

operable program or batch file.

I've tried cleaning the cache, deleting the node_modules, and re-running an npm install, but I get a similar error again.

enter image description here

If anybody's had any luck forking ohm's repo/deploying it locally please let me know!

1 Answer 1

1

Looks like the issue is that install scripts are expecting a Unix environment, while you are running on Windows.

You can install WSL2 which will create a linux (eg. Ubuntu) environment on your Windows machine.

You would then do all the commands (git clone, yarn, etc') in your WSL2 linux terminal. Then the install scripts would probably work.

You can even use VScode with WSL2 by typing code . in the directory you want to open in VScode.

1
  • 1
    Thank you!! This works perfectly. Installed WSL2 as prescribed :)
    – Tomasteel
    Nov 24, 2021 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.